Updating digital slr camera firmware

Rated 3.95/5 based on 550 customer reviews

Select the compressed, self-extracting file appropriate for your operating system and double-click to extract.

If the WFT-E2 / E2A is updated to Version 2.0.0, can it still be used with the EOS-1D Mark III and EOS-1Ds Mark III?

If the WFT-E2 / E2A has Firmware Version 1.0.0 or 1.0.1, can it be used with the EOS-1D Mark IV?

If the firmware of the WFT-E2 / E2A is Version 1.0.1 or earlier, the WFT-E2 / E2A cannot be used with the EOS-1D Mark IV.

Yes, the following improvements from the previous version are included: (Previous) Version 1.0.1 improvements: The shutter cannot be released after the camera enters image transmission mode while network errors are occurring due to an unstable wireless or wired communication environment or connection.

With this fix, the images taken will be stored in the recording media (CF card or SD card) even if network errors occur prior to or during image transmission.

Leave a Reply